Forgot password?
login to RetroAchievements:
User: 
Pass: 

Resident Evil 2: Dual Shock Edition


Page: < 1 2 3 4 5 6 7
AuthorMessage
wilhitewarrior
Posted: 13 Jul, 2021 19:58

wilhitewarrior
Posted: 18 Aug, 2021 18:14
Last Edit: 18 Aug, 2021 18:17

After getting a DM from a user, I decided to document here the exact requirements for an A rank because there's a lot of conflicting information on it online.

The reason there's so much conflicting info is that there is no one requirement for an A rank. The time requirement is dependent on how many times you've saved and on whether or not you've used any first aid sprays.

First aid sprays (Herbs are fine) and the use of special weapons also penalize your rank. The use of any special weapons at all will render an A rank impossible. Using more than 2 first aid sprays also will and every one you use will decrease your allowed time

The times here assume no first aid sprays have been used and no special weapons, obviously

0 saves   - <5:30:00
1-2 saves - <4:30:00
3-4 saves - <3:30:00
5-6 saves - <2:30:00
>6 saves  - Impossible
Lail
Posted: 23 Aug, 2021 01:35
Last Edit: 23 Aug, 2021 02:23

EDIT:
I just saw in the thread several pages back that LucasDragon13 was having the same issue as well. Anyone figure anything out?

ORIGINAL:
Anyone else having issues with the Leon-A campaign freezing at the very end of the game during the cutscene when
Spoiler (Click to show):
Ada is holding a gun on Leon asking him to hand over the G-Virus sample on the walkway


I was trying to consolidate playthroughs and decided to do the A-Rank Scenario A and No-Save Scenario A at the same time, so imagine how pissed I was when the game freezes at that point in the game on a no-save run... twice!

Then, I uninstalled RetroArch and re-installed it, and it worked, only for it to freeze again on another playthrough during the same cutscene.

The weird part is that it doesn't freeze at the same moment during the cutscene either. It's like it's hit or miss on whether the game will make it through that moment or not.

I tried Beetle PSX and PCSX ReARMed cores as well, which seem to be the most popular and that didn't make a difference either.

I'm using a .m3u file to play the game, but it also did it when I loaded Disc 1 directly.

Could it just be the ROM I'm using? I'm using the USA version and I've unlocked a bunch of the achievements already, so it's not like I have an incompatible version, but I don't know what to think of this... comments/thoughts/suggestions?
wilhitewarrior
Posted: 23 Aug, 2021 02:35

Ugh. That accursed crashing issue. I have looked into this, trying to reproduce it but I've been unable to myself. Still it's been reported by a number of users, so obviously it is a problem. One of the core settings may be the issue but I have no idea which one. It's unlikely to be the ROM or the achievements wouldn't work since there's only the one version linked.

I also don't know what video drivers you're using. I use Vulkan for mine. I don't know if OpenGL is causing this issue or not but it's a possibility

The only suggestion I currently have is to try it in the reverse order for now. Claire-A, Leon-B for the saveless run. It seems to only happen during that one cutscene as every single time it's been reported, it's always been there.
KickMeElmo
Posted: 23 Aug, 2021 04:21

While it -could- be your dump being faulty, it's hard to be certain of much without more information. Normally I'd be inclined to blame something like CD Loading Speed being too high, an incompatibility with dynarec, or similar. You might also try disabling the widescreen hack or PGXP if you're using those. The fact that it happened in both PCSX and Beetle PSX is rather odd though.
Superbegita
Posted: 24 Aug, 2021 18:12

For add to that i can confirm the game had problems with blackscreen on particular doors.

Mean the blue one to the east side, the big one.

And the autopsy one in the basement.

Note : only when you enter in the office NOT when you leave it for retrieve yourself the long corridor.

The loading cd are not the culpit and same for the PGX graphics geometry.

And OpenGL/Vulkan same for them problem occurs.

With Claire A by example. Already the game several times.

And it s THESE two piece.

Note : on the Duckstation android version NO problem at all.

I dont use Retroarch for ps1 games but only Duckstation.

On the pc version of Duckstation problem occurs sometime for the big blue door and ALWAYS for the autopsy one.

I knlw that the original one struggle with that, émulation is perfect tobthis point. (Blackscreen)
Lail
Posted: 24 Aug, 2021 18:19

It's only a sample size of one data point, but in the settings of RetroArch, I saw a "No Audio while Fast Forwarding" setting and turned it on.

The game did not freeze at the aforementioned cutscene (could have been a fluke), but I WILL say the entire game overall ran smoother from the fast forwarding I was doing.

So take that with a grain of salt.
wilhitewarrior
Posted: 24 Aug, 2021 23:53

Thank you for the info, I believe it is indeed the fast-forwarding that causes the crashing issue. I've added that to the top post to hopefully prevent future users from encountering this problem
Superbegita
Posted: 21 Sep, 2021 00:18

Game had problem on Duckstation look like well on Retroarch.. No problem with Duckstation standalone.

Problem encounter : no audio AT ALL...except the sound FX (footstep, weapons etc but no music at all).

Problem just encounter that...

Note personnal: on Android the save file create is strange and the space is interpret by the two signs : %20

I wonder if in fact Retroarch can't deal with the title write like that...

No change in the two bins by cd and cue...

Just try out the chd format for Wild arms (already mastering but for trying) and no problem but the file name is normal not strange as Resident evil 2

It's due to my android phone well when the save was created and for being able to use on my pc desktop and my phone i have had to rename the title like that exactly:

Resident%20Evil%202%20-%20Dual%20Shock%20Edition etc etc

I think it's Retroarch who can't handle the title (no problem for the standalne Duckstation)

I will try with Wild arms 2 for seeing if the problem is similar.
i2ocker89
Posted: 14 Jan, 2022 20:32
Last Edit: 15 Jan, 2022 01:10

Is there anyway to get achievements while using PBP files? Not 100% sure I know how to setup bin/cue files in my Psx rom folder. I just have all pbp files
KickMeElmo
Posted: 15 Jan, 2022 01:09

No, pbp is not supported and there are no plans to add support. It's not a very good format for general use.
i2ocker89
Posted: 15 Jan, 2022 01:41

Thank you for the response. I've been youtubing how to convert PBP to bin/cue files. Slowly start working on it
bornthisway
Posted: 15 Jan, 2022 02:07

Be aware that the bin/cue file has to match the hash linked to the cheevo sets. For PS1, hashes are tied to "ReDump" files.
KickMeElmo
Posted: 15 Jan, 2022 02:42
Last Edit: 15 Jan, 2022 02:44

Generally that won't be an issue for systems after N64 as long as the -version- is correct. RA hash for discs (and DS) is derived from the contents rather than the md5 of the file itself. That said, yes, we do use Redump's database for verification of clean dumps, since it's the best standard available to ensure we aren't working with corrupted garbage.
Page: < 1 2 3 4 5 6 7

login

login to RetroAchievements:
User: 
Pass: 
or create a new account