RetroAchievements logo


Page of 2 > 
SamuraiGoroh22 Jan, 2016 21:29(Edited 07 Apr, 2018 01:06)
Official Topic Post for discussion about Tetris (Game Boy) Tetris (Game Boy)
Created 22 Jan, 2016 21:29 by SamuraiGoroh

1. Tetris (Japan) (En).gb
Tetris (W) (V1.0) [!].gb
RA Checksum: 084f1e457749cdec86183189bd88ce69
CRC32 Checksum: 63F9407D

2. Tetris (World) (Rev A).gb
Tetris (W) (V1.1) [!].gb
RA Checksum: 982ed5d2b12a0377eb14bcdc4123744e
CRC32 Checksum: 46DF91AD

3. Tetris (W) (V1.1) [T+Por].gb
RA Checksum: d1feeed857f9010980b00bf53f749d61
CRC32 Checksum: AC1C4CFE

SamuraiGoroh22 Jan, 2016 21:32
If the NES version Tetris (Nintendo) (NES) Tetris (Nintendo) (NES) had some achievements, I don't see why not the GB can't. There where already some addresses mapped and even a Leaderboard, yet there are still no achievements done, shame.

I've mapped some more addresses, which should be more than enough to make some achievements, for anyone that wants to go ahead and create them.
SamuraiGoroh01 Apr, 2017 16:10(Edited 01 Apr, 2017 16:10)
Most of the achievements have some flaws, you only check if the scores are exactly the goal, but if you just jump and skip the comparison, you won't be able to trigger the achievement.

For example, Tetris Master Tetris Master (25) checks if score digits is 0x20, but I jumped from 0x19 to 0x21 and wasn't able to master the game
valkyrov05 Apr, 2017 15:08
Challenge achieves fixed to accept numbers greater than 20, I apologize for those that have to achieve them again as they are the hardest ones, but at least that work better now. Score achieves now accept the proper score and anything greater than the score.
SamuraiGoroh05 Apr, 2017 21:02
I don't know why I must do the achievements again, but I'll fix them (partially blame on me when I labeled the addresses)

It seems that address 0xfff4, while it is for the speed cheat (heart), it keeps track of the buttons you pressed (at least down+start), so while the expected combination is 0x88, you can have other (higher) values there.
valkyrov06 Apr, 2017 01:01(Edited 06 Apr, 2017 01:01)
Good job "fixing them". Don't know what you did but now the challenges pop when you start b mode on 9. Everything is jacked :/ They worked just fine, I kind of wish once you made achieves others couldn't edit or just delete them to make their own set. That's the only downfall to this site. I will say that since you messed it up it's up to you to fix them. So, would you kindly?
SamuraiGoroh06 Apr, 2017 01:40
Thanks for the sarcasm @_@

Despite the achievements saying you must play in Mode A or Mode B, it was YOU who never checked that. I'll add all the checks the achievements should initially have according to your rules & explain were your error was.
SamuraiGoroh06 Apr, 2017 02:04
So, here's the explanation of what was wrong since the beginning (meaning the original code).

The scores you assume you can only get them in Mode A, so you never checked which mode you were playing. While in theory some achievements may not be possible in such short time, it was an overlook of you, which you made on all achievements.

In order to check which mode you are playing, you can use the address 0xffc0. This one can have 2 values, either 0x37 or 0x77. Since only the bit6 is different, you can simply compare it to know which mode you are playing.

Also, score achievements only had 1 condition & that usually makes achievements fragile. You should always try to add a condition that avoids common values like 0x00, 0xFF and for the SNES 0x55 in order to avoid false triggers. This is because occasionally when you reset the game, the address might change for a frame to any value (one of those 3).

If you select one more (say Mode B, Level 9-5) and then change to the other (Mode A), the addresses that you used would still be valid, which would had caused the achievements to trigger too when they shouldn't.

And finally, IMO just having 400 points for the sake of it seems like a poor choice. There are no challenges like pulling X number of Tetrises or similar.

So in resume, not because achievements work when intended, means they are correct, as you can also trigger them when you're not supposed to (which is what happened here)
valkyrov06 Apr, 2017 05:50
Mode B only allows you to do 25 lines so you can't acquire any of the scores I put down on Mode B, On the challenge achieves I had it set to check mode A, but hey, you claim I didn't and that's fine. Take over the whole thing if you need too, all I know is I spent hours testing everything and my stuff worked other than accidentally going over scores and I fixed that.
valkyrov06 Apr, 2017 05:52
Also I don't get why you didn't just make the achieves in the first place if you want to be so fickle about it.
chashodges12 Sep, 2017 21:21
Hi all. I don't seem to be able to unlock either 'Challenge of the Best' or 'Challenge of the Gods' using Retroarch. Has anyone else managed to get this using Retroarch or only using the RA emulator?
Thoreau16 Jun, 2018 02:14(Edited 16 Jun, 2018 02:20)
The way Challenge Of The Best Challenge Of The Best (25) and Challenge Of The Gods Challenge Of The Gods (25) are working right now is that you should use the speed cheat to start and reach 20 lines while you are EXACTLY at speed 15 for the first one and speed 19 for the second one.

There's a detail, though: if you start at speed 15, when you reach 20 lines you will already be at speed 16+, same thing for when you start at speed 19, you will already be at speed 20+.

So, to trigger them as the code is today, you need to start at speed 14/speed 18.

I just sent valkyrov a message asking what exactly was his intention here, so we can improve either the description or the code.
fl04t26 Apr, 2019 03:53(Edited 27 Apr, 2019 20:21)
I'm sure there's something I haven't read somewhere, but I can't get achievements to trigger at all for this game. Tried with two different hashes, and I don't know what else to do.
S4g4tNL02 Jan, 2020 14:01
If the hash is correct then cause should be wrong or outdated core or emulator.
webdevkit02 Mar, 2020 12:28(Edited 08 Jul, 2020 22:14)
Page of 2 > 

You must log in before you can join this conversation.