Forgot password?
login to RetroAchievements:
User: 
Pass: 


RetroArch not unlocking achivements

AuthorMessage

PheonixGRX
Posted: 07 Aug, 2019 09:06
Last Edit: 07 Aug, 2019 09:43
Hey, I was wondering if anyone could help me with this. I've used the RetroArch program in the past and it has worked rather well, however recently I opened it to play some games and I noticed that games are no longer unlocking achievements for me. It registers that I am online, tells me that I have 0/XX achievements unlocked, and my profile on here even says that I have played the game, however the achievements just aren't popping. Does anyone know a way to fix this?

EDIT: After reinstalling the program, I seem to have achievements for GBA working, but other consoles like the Sega Genesis aren't working properly.

Blazekickn
Posted: 07 Aug, 2019 19:30
What cores are you using? Not all cores work for cheevos.

jos
Posted: 07 Aug, 2019 19:42
What Blaze said, also update the cores if you haven't done it yet, and if it still doesn't work, enter again the login information and then restart Retroarch.

PheonixGRX
Posted: 08 Aug, 2019 01:39
Oooh, I didn't know it was a certain core for certain ones. A lot of the GBA ones were working and I had assumed they all worked similarly. Is there a list of cores that are supported?

LordArchantos
Posted: 08 Aug, 2019 21:03

Xymjak
Posted: 09 Aug, 2019 13:10
This list is not fully correct.
For example: Snes9x often don't unlock achievements that work fine with Snes9x 2010.

LordArchantos
Posted: 09 Aug, 2019 14:57
Indeed it's not. Sometimes updates and changes break core's compatibility completely or partially, like is currently the case with Gambatte and SameBoy as well. I don't know how often the list is updated, but it's the best general guideline currently.

PinkFoxy
Posted: 13 Aug, 2019 15:02
this community is awesome, just throwing that out there >.<

MatheusBrazuca85
Posted: 13 Aug, 2019 22:19
I wanted to say, Snes9x core is a lot bugged in retroarch

login

login to RetroAchievements:
User: 
Pass: 
or create a new account