Forgot password?
login to RetroAchievements:
User: 
Pass: 

Latest 0.073 Update Broke Everything

AuthorMessage

Raukue
Posted: 08 Sep, 2018 00:24
This happened a few days ago and I see no one mentioning it so maybe it's just me? But the latest toolset has cause the emulator to not work anymore. The moment I open it up, it crashes instantly. I have deleted the dll file to grab it again as well as manually and nothing. This happens both for NES and N64 ones which I updated.

Jamiras
Posted: 08 Sep, 2018 00:59
There are three known issues in 0.73:
* Cannot edit code notes in WinXP
* Overlay sounds are sometimes replaced by standard windows sounds
* Emulator crashes if run from a path containing accented characters.

You're most likely experiencing the last item.

Having fixed the last of those issues yesterday, I'm hopeful that we can release 0.74 this weekend to address those issues. I apologize for any difficulties this has caused.


Raukue
Posted: 08 Sep, 2018 03:18
Last Edit: 08 Sep, 2018 03:19
Well it's not the accented characters. I had it in a folder called @Emulators RetroAchievements.org and moved it out of there and it still instantly crashed. It plays the login sound or part of it before it crashes. I even deleted the config which allowed me to re-login but as soon as I did it crashed. With N64 emulator I can open it just fine it's just one I choose a game to login is when it crashes. I have Windows 7.

Least good to know not just me and it's being looked into. Thanks for the reply. Don't know how to see if it's those other issues.

Altomar
Posted: 08 Sep, 2018 04:46
Last Edit: 08 Sep, 2018 04:47
Have you tried to download again any of these emulators just in case and put them on a new folder (do not overwrite the old forders)?
Because i use win7 64 bit and at least N64 works fine with the new dll.

Jamiras
Posted: 08 Sep, 2018 14:54
Last Edit: 08 Sep, 2018 14:55
If your "@Emulators RetroAchievements.org" folder is under your user folder, the accent may not be immediately visible. Your user folder is typically in "C:/Users/Username", so if your Username has an accented character, or "Users" translated does (i.e. "Usuários"), those will be included in the full path: "C:/Usuários/Adrián/Downloads/RAGens" even if Windows only shows "Downloads > RAGens". Click on the Path field to see the full path.

The timing of your issue (while playing the login sound) really sounds like the accented path issue. Can you PM me the full path to your emulator? Either here or on Discord.

Raukue
Posted: 09 Sep, 2018 08:18
I suppose I can Discord, though who to message there? But yes I am aware. There is nothing like that in the full path. Just my name and none of it has anything like that. I did move the folder to "C:/Games/RANes" and it still failed.

@Altomar
I just tried to that after what you said and same thing happens. Even if it's in a new folder the NES emulator still crashes, that's the one I keep testing. The N64 one loads up just fine with the ROM list but once I choose one then I get the crash. Just tried again to be sure.

Jamiras
Posted: 09 Sep, 2018 13:40
Last Edit: 09 Sep, 2018 13:41
0.074 (which includes the fixes for the issues mentioned above) was released today. If you're still having issues message me.

rendakiro
Posted: 09 Sep, 2018 20:10
Last Edit: 09 Sep, 2018 20:28
good afternoon. The same thing happens to me in win 10 and wun7, does anyone know the dependencies of RA_.DLL?

Raukue
Posted: 09 Sep, 2018 23:42
Still same issue. Dunno what happened. Maybe it's just my end but I changed nothing from before this update, when it was working, as it always has for past few years from the same directory I had it at... and now it does not.

I opened Snes9x now and course it too now crashes with the new update. Wish it were easier for you to know what the issue is. It can't be accented characters as I have none of that in the path and even moved it around to as simple as can be.

The emulator stays open as long as I do not log in. The moment the login sound plays, just as it starts, instantly crashes.

Altomar
Posted: 10 Sep, 2018 04:12
Last Edit: 10 Sep, 2018 04:18
Do you have any extra firewall installed other than windows default?
It's strange that it crash as soon as you try to login and the first think that came on my mind is that a firewall is trying to block it / put it to auto containment.
I tried to run all the above emulators on my PC (win7 64bit) and they work fine.

Jamiras
Posted: 10 Sep, 2018 04:40
It is most likely an issue with the user image. It sounds like the login sound is starting to play, which means the server call to login succeeded. Showing the user image on login is new in 0.073, but it's the same code that shows the badges when an achievement is triggered. I was really hoping it was the pathing fix (which was also related to displaying the user image, but would have caused other problems later as well).

Without being able to reproduce locally, all I can do is provide the user with custom builds that have additional logging or disabled functionality until we can identify what the problem is. That's difficult to do through a forum.

Raukue
Posted: 10 Sep, 2018 09:07
Ah looking at the user image, yeah. A new image created Sept 1 and it's called "_User" and is the default avatar used on this site. When I load up a N64 ROM it DOES pop up on the lower left for a moment before crashing. NES and SNES crash before even that shows up.

Raukue
Posted: 11 Sep, 2018 02:10
Nice. All is well and working again. Thanks for the help.

Jamiras
Posted: 11 Sep, 2018 04:02
A server-side fix was made to address the issue Raukue was experiencing. Because of invalid data in the database, the client received something it wasn't expecting and barfed.

login

login to RetroAchievements:
User: 
Pass: 
or create a new account