Forgot password?
login to RetroAchievements:
User: 
Pass: 

Achievements not working with RetroArch

AuthorMessage

HalfOfAKebab
Posted: 16 Aug, 2018 04:40
Last Edit: 16 Aug, 2018 09:55
As you can see from my profile, I was playing some SM64 (via Mupen64plus) and unlocked a few achievements. Then, due to an unrelated issue, I reset all my configs and did a clean install of RetroArch. Suddenly, achievements stopped working.

Here are my achievements settings. It's all enabled, yet when I open the quick menu after starting SM64 and open the achievements menu, it simply says "no achievements to display". I'm using the exact same ROM file I used earlier when it was working, so I have no idea what could have caused it to suddenly break.

I think I have an idea where the problem is, though. In retroarch.cfg, there is no cheevos_token like there was before when it was working: `cheevos_token = ""`. All the other `cheevos_` lines look fine and dandy. I have no idea what my token is or where to get it. I thought it might be my API key, but the API key in my settings on RetroAchievements is way longer than the token that was in the cfg before, so I'm lost.

Yes, RetroArch and Mupen64plus are updated to the latest versions. The MD5 checksum of my ROM is `20B854B239203BAF6C961B850A4A51A2`, which is on the list of supported hashes for SM64.

I'm really lost. I've been Googling it, but the only other guy I could find that has had the same issue turned out to have an unregistered RetroAchievements account, which isn't the same issue as mine - you can see on my profile that my account is registered.

Any ideas?

Altomar
Posted: 16 Aug, 2018 12:14
Double check that you typed the correct password. On Settings menu select User (3rd from the bottom to make sure your account settings is created and retype your password just in case.
The first time i wasn't able to connect for some reason.

HalfOfAKebab
Posted: 17 Aug, 2018 00:00
I've already made sure it's correct. I've also cleared my password and typed it again just to make sure, to no avail.

HalfOfAKebab
Posted: 18 Aug, 2018 13:48
Bump

coldjacket
Posted: 18 Aug, 2018 14:28
Last Edit: 18 Aug, 2018 14:28
uninstall retroarch. try a fresh retroarch install. I know that m64 ron worked with you on that core before. but maybe you can test another console/core like nes or snes. just try isolate the retroarch retroacheevo issue.

PlaidZombie
Posted: 29 Aug, 2018 15:40
Last Edit: 31 Aug, 2018 12:54
Did you manage to fix this at all? I'm having the same issue. Was working fine and now I see "no achievements to display"

guitasousa
Posted: 02 Sep, 2018 11:05
não estar funciona as conquistas no battletoads in batllemaniacs

guitasousa
Posted: 02 Sep, 2018 11:09
Bate o jogo sem continue com o pimple e os 400 pontos no bônus estágio 2 , essas conquistas não estão disparando . Jogo - battletoads in battlemaniacs emu rasnes9x



Foram mais de 20 vezes jogando ao vivo mas as conquistas não disparam . Obs; nos outros jogos funcionam .

nathannxn
Posted: 02 Sep, 2018 18:43
Last Edit: 03 Sep, 2018 15:20
Im having the same issue. Also RANes isn't giving me achievements either.

tipau
Posted: 04 Sep, 2018 11:45
Last Edit: 04 Sep, 2018 11:53
Hello,
I use retroarch on Android with my Smartphone.
When i play with FCEUmm with wifi i see the list or achievements but when i disable wifi and use 4g it's written no achievements to display.
I don't know why

almozayaf
Posted: 14 Sep, 2018 05:43
You need internet for the achievements.

If you didn't log in you got nothing

tipau
Posted: 14 Sep, 2018 13:37
Hello,
I have internet i use the 4G connexion of my Smartphone.
But the functionality seems not working with it. It only works when wifi is activated.

login

login to RetroAchievements:
User: 
Pass: 
or create a new account