Forgot password?
login to retroachievements.org:
User: 
Pass: 

Server Upgrade September 2017

Page: 1 2 >
AuthorMessage

Scott
Posted: 11 Sep, 2017 17:57
Last Edit: 06 Oct, 2017 09:47
We are now using a t2 .medium rather than t2 .small server to cope with our needs. We are growing!

Thank-you for your patience as we fix any teething issues we have while transferring over.

Please leave a message here if you spot something that needs fixing!

-----------------------------------------

Currently known issues: (as of 6 October 17)
1. Rich presence errors:
* Unable to add or edit. Doing so erases everything
* Online now is not showing everyone

2. Apostrophe Title Errors:
* Making a new entry with an apostrophe (') displays a quotation mark (")
* Same for editing a title. Unchanged titles retain the apostrophe.
* One cannot link a game checksum to an entry with an apostrophe (')

3.Missing Avatars: During a window some users did not get a default profile. Slightly breaking the site in some places: Examples: , , .

4. Text Accent failure:
* Changing a forum title with some accents (such as Cyrillic) will not be accepted by the system.
* There was a one time corruption of Cyrillic Portugese accents and others on the site. Can this be reversed? See (defaultconnectioncollation https://pma.nic.ru/doc/html/config.html#basic-settings)

5. Leaderboard errors:
* Devtool: Reordering leaderboards does not work; their numbers save but they still display by creation date.
* Submitting a better score does not update the date.

Scott
Posted: 11 Sep, 2017 17:59
Last Edit: 13 Sep, 2017 18:11
It seems that new users aren't getting avatars, and I can't submit images in the news updates. I also can't post news updates :(

There's also an issue with Code Notes not being uploaded...

MGNS8M
Posted: 11 Sep, 2017 18:04
Last Edit: 13 Sep, 2017 18:12
Not sure if it's already known, but search and search-preview also do not work.

kdecks
Posted: 11 Sep, 2017 18:44
Last Edit: 19 Sep, 2017 00:14
besides what has been noted:

Making changes to rich presence send me here: http://retroachievements.org/submitgamedata.php . On this page there is only a "#" in plain text. No change is made.

Getting a server error 500 when submitting a search request, attempting to view "my tickets", removing an entry from a leaderboard, or when sending messages.

Some accents and other text are not reading correctly. E.g. http://retroachievements.org/Game/126 this may be a one time corruption.

tuinj
Posted: 11 Sep, 2017 18:56
Last Edit: 13 Sep, 2017 18:26
you cant save code notes, its already told by shikamaru but just to list it up i'll post it here. if you click onn save it says could not save not, check if youre logged in and retry

ThatOneEnderMan
Posted: 11 Sep, 2017 19:02
Last Edit: 13 Sep, 2017 18:29
On the RANES and RASNES emulators, it can't seem to update to 0.62 for the toolset, thus making it impossible get achievements with the emulators. Don't know if this a problem for myself or what.

NickGoat1990
Posted: 11 Sep, 2017 19:45
Last Edit: 13 Sep, 2017 18:29
I have the same problem about updating the toolset in RASnes, gives me a "Problems writing file!" error message, I downloaded this emulator for the first time last night.

Deleting RA_Integration.dll and then trying to download it through the emu gives the message: "C:...RA_Integration.dll is either not designed to run on Windows or it contains an error. Try installign the program again...etc."

Using the DLL from another emu, I managed to skip the toolset update and let the emulator log in, I noticed I had RASnes 0.015 instead of 0.019

EDIT: I created the folders RACache->Data so I could get a log file, this is all it shows.. "RA_KillHTTPThreads called"

luchaos
Posted: 11 Sep, 2017 20:42
Last Edit: 13 Sep, 2017 18:30
comments on profiles seem to be broken - getting a 500 server error when trying to post one on my own
nothing else in the xhr response body
not sure if this is related to the upgrade though

Totaya
Posted: 11 Sep, 2017 21:03
Last Edit: 13 Sep, 2017 18:17
"All my tickets" page doesn't work, it's a blank one instead.

Shikamaru91
Posted: 12 Sep, 2017 07:43
Last Edit: 18 Sep, 2017 23:57
I suggest removing all emulators (except RAmeka and RAProject64 because these aren't concerned) from the download page because they're old versions; at least, until the problem is fixed.

Like I said on discord, trying to submit game info/screenshots leads to the same page posted.

salvadorc17
Posted: 12 Sep, 2017 14:31
Last Edit: 13 Sep, 2017 20:00
I will recommend an update for RAPCE, could i be on charge for that?

kdecks
Posted: 12 Sep, 2017 18:14
Last Edit: 18 Sep, 2017 23:57
Unable to change profile pictures or leave comments on game/achievement pages, upload badges.

Luckily the forum still works.

Due to what shika said you won't be able to use the download page and get the right files. Get the correct files here: http://ra-mirror.lupinedream.com/ or come to the #help-me channel (https://discord.gg/FswPDnu). Look at pinned messages to get the latest version of emulator and .dll.

kdecks
Posted: 13 Sep, 2017 18:36
Last Edit: 13 Sep, 2017 18:38
I've updated this thread crossing out everything that has been resolved, covered somewhere else more clearly or is irrelevant.

New users accounts since the update are not getting avatars.

Everyone keep adding any issues if you find any! Thanks everybody.

MGNS8M
Posted: 13 Sep, 2017 20:10
Uploading a new Game-Icon for a game-profile isn't working .. assuming the other game-profile-image-uploading doesn't work either. I've also un-striked "irrelevant" comments, that isn't necessary.

BenGhazi
Posted: 14 Sep, 2017 00:48
Last Edit: 19 Sep, 2017 00:07
Not sure if this is an isolated issue or if it's a site-wide problem but the twitch video
http://retroachievements.org/Achievement/2985 doesn't seem to work.
Page: 1 2 >

login

login to retroachievements.org:
User: 
Pass: 
or create a new account