Forgot password?
login to retroachievements.org:
User: 
Pass: 

Ootake / RAPCE emulator bugs

Page: 1 2 >
AuthorMessage

Brian
Posted: 11 Feb, 2014 08:32
Probably one problem for the following:
- Clicking [Load CD-ROM Game] crashes the emulator
- Submitting a new game title crashes the emulator
- Resetting a game that's already running crashes the emulator
- Loading a new ROM while one is already running crashes the emulator

Probably one problem for the following, or it's also part of the previous:
- Closing the emulator keeps the process running with all windows closed
- ^Due to the above, attempting to start the emulator will immediately close it
- Manually killing the process fixes the above
- Due to all of the above, none of the emulators settings are saved on exit, because it doesn't close properly.
- ^I have to reconfigure pad input every time I start the emulator

- No compatibility mode combinations fix any of the above
- Changing emulator settings don't seem to affect the above

- The first-launch help message from RA Integration says keys [ASD] = Buttons ABC. This does not seem to be correct, and S is savestate
- I don't know when to use 2/3/6 button pads or a mouse



----- Other stuff you may or may not be able to fix -----
- Dev tools load/refresh very slowly
- Creating a Savestate will make the overlay pop in and out for a moment, though this doesn't bother me at all.
- I selected a default badge for all achievements I retroachievements.org/Achievement/4948 earlier, and they don't appear to have a badge at all on the site. Blank. Only PCE.

Scott
Posted: 11 Feb, 2014 09:24
Wow it really is a mess isn't it lol great bug reporting Brian, I'm wondering whether to drop or change the emulator, ootake was incredibly easy to integrate into, but maybe not the most user friendly?

You're completely right about it not saving on exit if it doesn't exit - I can't quite see how or why it isn't closing though, some sort of locks thread? Hmm...

Fantastic list though, this is exactly what I need to improve it, a verbose, clear, precise bug report exactly like this. Thankyou Brian!!

Brian
Posted: 12 Feb, 2014 03:32
Maybe this is why Chokko is still seen as playing R-Type. The process is still running.

yoyo
Posted: 27 Feb, 2014 12:41
Ootake is a good emulator, in fact, a great emulator, but this definitely needs some fixing up and the newest version should probably be grabbed if this isn't it. I have my own Ootake on the side and it saves my settings just fine. I can't seem to find anything that changes the setting, lest any differences from the settings here and my emulator, except when I change them to what settings my emulator are, they don't save :(

jackolantern
Posted: 01 Mar, 2014 00:44
I don't know if htis affects anyone else but when I load the emu it's at 3x size. If I don't make the screen size smaller and open the dev tools the windows vanish off the screen, I either have to line up the windows using a windows tool or close and re-open the emu to get the dev windows to appear.

Scarlatti
Posted: 22 Jul, 2015 14:13
Last Edit: 22 Jul, 2015 19:24
Hi everyone, I tried a lot to make Rondo of blood works on RAPCE but it doesn't, it crashes all the time or when I installed the bios Super cd 3.0 and mount the .cue file, it says "the cd is not loaded", I did it with Deamon Tools and Virtual Clone drive and the cd was loaded in the right place.

How did people manage to get it works ? Does it works perfectly for you ?

Thank you for your attention.

Xim
Posted: 10 Mar, 2016 12:21
Last Edit: 10 Mar, 2016 16:37
Hi everyone!
French newbie here... I have to put on the hardcore mode every time i login on RAPCE, and since i can't reset without crashing the emulator, i can't play on hardcore. Any help ? Thx a lot!

kurt91
Posted: 30 May, 2016 02:42
Last Edit: 30 May, 2016 14:39
I've never been able to get the PC Engine emulator to work either. Would it be possible to set up the Achievements system on something like Retroarch? Those emulators are easy to work with, and once the Achievements are working, it would be able to work on stuff like Nintendo 64 and PlayStation.

kakarotto
Posted: 14 Mar, 2017 02:55
Last Edit: 14 Mar, 2017 05:29
Hello, i'm sorry to ask you that, but i have a probleme with RAPCE, i've up the iso with daemon tools, but when i start the loading, i have a white screen and it remains like this, what is the probleme, have you any advice please.
Thank you all.

MGNS8M
Posted: 14 Mar, 2017 15:56
Last Edit: 14 Mar, 2017 15:58
Sometimes if you don't open a game with command-line, RAPCE will crash on-load. If you open "cmd" and navigate to the folder with with RAPCE, you can load a CD game by loading the system-hu-card, which is easier to do if it's in the same folder as RAPCE.

For instance, I type this in a Command-box - rapce syscard3.pce

This will only load the system-card, which is expecting a CD to be in the drive...if the wrong-drive is selected by default, you will need to switch drives, which sometimes causes the emulator to crash. It might be that mine doesn't crash because I have the original Ootake-specific-version's config-file in the same directory(which can sometimes cause problems actually), but I'm not sure. Well, one thing I just realized is that my config file for Ootake just made the Achievement Overlay disappear, so I had to delete it again. Oh well.

If you want to close the emulator, you'll either need to kill the process in Taskmanager, or with the same command-box, type "tskill rapce" to kill the process. It usually won't close on its own, and it might be the reason why RAPCE crashes when trying to load a new game from the menu.


As kind of an optional, advanced process here:

You also have the option to "install" the game to a folder so you don't have to use MagicDisc or Daemon Tools(this will create a second copy of the game, just so you know). The catch is that you CAN'T load the installed game from the load-menu without the emulator crashing, you have to do it from Command Line, and the only way to do that is to type out the ENTIRE gibberish that it creates when having installed a game. Or Copy-Paste the directory-name.

You can't rename the ISO/CUE it creates, and you can't rename the directory it creates ... I'm sure it must be stored somewhere but I haven't found it yet(it's not in regedit and I don't think it's in RecentRom.dat either). So it's kind of a pain to start manually with a command-line, but it's the only way I know to start an installed-game without crashing RAPCE.

Which by the way, right now the syscard3.pce will load Rondo of Blood no matter what game you load, so it needs to be relinked at some point...but in order to do that I need to get Salsa's modified IPS patch for a copy of the syscard. Otherwise it will always load CVRoB no matter what game you load when you use that specific system-card. On top of that, the set for CVRoB needs to be fortified because if someone accidentally loads the wrong game on that system-card, it will easily pop every achievement early and that needs to be protected against.

And that's kind of a problem with command-line loading with "installed games" is that it will automatically use the system-card that you last set without letting you choose one, so in order to make it run the right installed-game, you'll need to first load the system-card itself, tskill rapce, then command-line load the cue file with its really long file-name.


In other words, right now it's a really long process to make things work efficiently and actually connect up the way they should. Apart from RAGens it's the worst-integrated emu here, which is why there are so few game-sets developed for it.

kakarotto
Posted: 14 Mar, 2017 18:23
I thank you for all this information, I will test all this and I will tell you if it worked but it looks complicated, moreover it is with "rondo of blood" that I try to make it work .. .
I will still try to follow your advice
thanks again bro.

Protoblubb
Posted: 12 Apr, 2017 18:44
Last Edit: 12 Apr, 2017 18:47
Nevermind, just delete this. Was already reported in the OP.

sylar632
Posted: 07 Jul, 2017 08:45
Excuse guys! Maybe I have passed something! But I have a problem with preservation of settings by the RAPCE emulator. If to change management, then after closing all settings will be reset! How to solve this problem?

MGNS8M
Posted: 07 Jul, 2017 13:50
There's no current solution to that unfortunately. Someone has a fix in the works that makes RAPCE work almost completely flawlessly, but that version is not public yet, and he still needs to block a few things the original left-out before it can really be used by anyone. Otherwise if that one ever goes through, it's much much better than the way RAPCE is right now.

sylar632
Posted: 07 Jul, 2017 14:00
Offensively to tears!!!
Page: 1 2 >

login

login to retroachievements.org:
User: 
Pass: 
or create a new account