Forgot password?
login to retroachievements.org:
User: 
Pass: 

"Problems Writing File"

AuthorMessage

LibelLawOpener
Posted: 19 May, 2017 00:03
So apparently, due the RANes update not installing, I can't log in and get acheivements. The problem seems to be with RA_Integration.dll

Any work-arounds?

MGNS8M
Posted: 19 May, 2017 00:33
Delete RA_Integration, maybe even RA_Keys. After that it should redownload without needing to overwrite anything, so it should download correctly.

soulrider25
Posted: 21 May, 2017 05:04
Last Edit: 21 May, 2017 17:35
Well I don't know if they fixed it in the official version but what've seen is that dll attempts to write to the log file in a folder that doesn't exist. Sure "a", is the appending filemode and creates a file that doesn't exist but it does not create a folder. This isn't Linux... GCC and clang have that functionality but not VC++.

My proposal fell on deaf ears but the fix is really simple. Just make sure all directories exist when the server version is newer than the client version. If they don't just create them. It's as simple as that.

soulrider25
Posted: 21 May, 2017 17:38
Last Edit: 21 May, 2017 17:39
I'm assuming you downloaded a new RA client version (RANes). There actually is a work around from the root folder make a folder RACache and one inside it called Data.

Ronanfalcon
Posted: 01 Jun, 2017 04:04
Last Edit: 01 Jun, 2017 04:08
This was happened to me in all emulators. Deleting RA_Integration solved for me only for Snes9x and VBA, all the others, like the Nes are still with problems.
Even the message "LoadLibrary 126" has appeares after I deleted the RA_Integration.

jerkwad152
Posted: 07 Jun, 2017 07:57
Reinstalling RASnes9x and deleting RA_Integration solved the login issue for me, but the game list is hosed and trying to fetch the latest achievement sets does nothing.

Jungon
Posted: 19 Jun, 2017 21:49
Last Edit: 19 Jun, 2017 22:57
I have this error too, plus can't login, can't see some parts of the forums, can't update emulators, and the download page still shows the old versions I started with, maybe it's because I was off for 9 months playing pokemon go but now that I'm back, I would like to solve please these problems and achieve the achievements, especially on RAMeka which I can't download yet, too >_<


"You don't have permission to view this page! If this is incorrect, please leave a message in the forums."

Oh, and this is showing on some topics,.. what do I do? I wanna play =(

Raukue
Posted: 12 Sep, 2017 01:02
I just had this issue with RANes. Deleting those files did not work. But what did work was copying the files, RA_Integration and RA_Keys from a working emulator, such as the GBA emulator, made it work.

login

login to retroachievements.org:
User: 
Pass: 
or create a new account