Forgot password?
login to retroachievements.org:
User: 
Pass: 

RASNES Black Screen on Rom Load

Page: 1 2 >
AuthorMessage

MRTNT140
Posted: 17 May, 2017 12:59
Last Edit: 17 May, 2017 15:11
Befor the uptade 0.17 i was playing some games like super mario world and the legend of zelda
now after the update i can open the emulator but when i select a rom nothing appens
someone can help me?

AlexandreBR
Posted: 17 May, 2017 22:12
Same problem here.

Salsa
Posted: 17 May, 2017 22:44
You can't execute the ROM? How did you updated the emulator?

Olafur
Posted: 18 May, 2017 00:47
Last Edit: 18 May, 2017 01:12
Same here, I just downloaded my first rom and I'm stuck at black screen.

Tonius
Posted: 23 May, 2017 15:06
same problem

Dexterspet
Posted: 25 May, 2017 18:52
A solution was recently found for those who haven't solved this problem yet, your RASNES9x folder can't be in a directory with an "invalid character" or it will behave like described. Uploading achievement icons on RAVBA will also crash that emu if it's in a directory like this.

Invalid characters can be any accented letter and some symbols. Just mess around with putting it places until you find out what works.

Olafur
Posted: 25 May, 2017 20:15
Last Edit: 25 May, 2017 21:15
That's definitely not me then, it doesn't seem like it's in a directory like that and it's in the same one as my RAVBA and it doesn't crash when the achievement icons pop up. It's only the SNES one that's buggy for me.

Edit: Just saying I moved it to several other folders, changed my username to remove any "foreign" letters, reset my laptop, troubleshot it, ran as administrator and STILL it's stuck at black screen.

Dexterspet
Posted: 25 May, 2017 22:16
Could the name of your PC be foreign? Unless that's what you mean by 'username'. Any folder along the directory path can ruin it. And when I say RAVBA crashes I mean when you UPLOAD an achievement icon to an achievement in the achievement editor, not just loading it.

I'm sure there's other ways this bug can happen. Other symptoms that I found in testing were that on a fresh download, RAKeys.dll and snes9x.conf didn't get created at all and it won't read either file whatsoever if you put another one in there. Perhaps you could test that and the image upload bug to see if it's the exact same issue as I've seen? It could have a similar root problem leading to it.

Olafur
Posted: 25 May, 2017 22:25
Well, I live in Iceland, but I made sure there are no non-english letters there, and the directory path, if I'm getting it correctly is Desktop --> Retro Achievement --> SNES. But wait, that could be it! I don't see RAKeys.dll and snes9x.conf in the folder at all! Is it possible to send me these two files?

Dexterspet
Posted: 25 May, 2017 22:53
Last Edit: 25 May, 2017 22:55
Well the full name of the directory is Computer > [PCName] > Users > [UserName] > Desktop so even though it's not showing in the file explorer all of those paths could mess it up. It is my understanding that both are easily changeable if they contain "foreign" characters. As I said, even if you copy RAKeys.dll and snes9x.conf into the folder it won't read them at all, otherwise it would create them when you launch the emu. The RAKeys might be a file with account info in it that you shouldn't give out or something, I'm not really sure, so taking somebody else's isn't safe and might not even work. (even if it did read it)

If you still can't find out how to fix it, you can always try using Retroarch which is compatible with RetroAchievements. It just requires a little extra setup and using the right core, and its snes9x core doesn't have this issue as far as I know.

Olafur
Posted: 25 May, 2017 22:59
ah i see, i see, but still, what else could there be? There's no foreign characters on either at all, both VBA and NES works smoothly, but SNES doesn't. What else could there be?

Dexterspet
Posted: 25 May, 2017 23:03
Well if you're sure there's no foreign characters in either then it's a similar problem in that the RA integration can't read your path to create/read the RAKeys and .conf probably. RA_Integration and RA_Prefs get created correctly but I think the Keys and .conf are created differently. I'm not sure what you could really try since I've only heard of the solution I mentioned, except maybe putting it in the root of your C: drive if you haven't tried that already? You might just have to wait for a fix on the toolset side of things since it seems a toolset update is what caused it to behave this way to begin with.

Olafur
Posted: 25 May, 2017 23:16
hmmm, yeah there arne't any and tried reinstalling it one more time and putting it in the C: drive, or I think I did not quite sure, still nothing. Alright, I'll wait for the toolset update, that might fix it. Thanks for trying anyway and sorry for all the questions :) just one more, if you don't mind it, any idea when it'll be ready? :P So excited to try some SNES classic for achives :P

Dexterspet
Posted: 26 May, 2017 02:20
I have no clue when the toolset will be fixed, but as I said if you really wanna play SNES on RA in the near future you can download Retroarch and set up Retroachievements with that.

Olafur
Posted: 06 Jun, 2017 12:53
hey, it's me again, I noticed the new version, downloaded it, still stuck in black screen. Why? I thought that was the toolset fix. Or wasn't it?
Page: 1 2 >

login

login to retroachievements.org:
User: 
Pass: 
or create a new account