Forgot password?
login to retroachievements.org:
User: 
Pass: 

log of experiences with RetroArch and-or the achievement itself

Page: < 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 >
AuthorMessage

Keysersoze77
Posted: 30 Jan, 2017 09:19
Last Edit: 30 Jan, 2017 14:45
I just wanted to add a problem with Retroarch on the Raspberry Pi 3: I was going for the achievement in and it didn't work with Retroarch on the Pi. I tired it on my PC and everything worked over there.

ivesmt666
Posted: 05 Feb, 2017 20:34
Last Edit: 05 Feb, 2017 20:35
I'm going to create another account to test these achievements by the retroarch retropie and android. Make sure you're using the US roms, i will experience this your conquest thereI have not had problems with the games of snes in the retropie, so I mapped the result,

Retroarchtester
Posted: 05 Feb, 2017 21:36
Last Edit: 06 Feb, 2017 00:41
Hello Friend. I am myself again I created another account to test and the conquest worked with me, as you can check in this profile, I used the rom emuparadise (U) and retroarch android updated, I am sure the same will work with retropie on the raspberry pi. thank you

Keysersoze77
Posted: 06 Feb, 2017 09:56
Thank you for testing it. That is really strange! I'm sure that I'm using the US rom. I will try to update Retroarch from source and hopefully everything else will work then.

Grenade44
Posted: 06 Feb, 2017 12:09
what emulator are you using? Snes9x-2010 is recommended.

Keysersoze77
Posted: 06 Feb, 2017 13:24
That's the one I'm using. I still got this problem. :(

ivesmt666
Posted: 03 Mar, 2017 23:33
I need help to configure the pc engine, in retroarch, mainly this game where I managed to work on windows, I think we have a question about the filename. In the windos was asked to inform the name of the game and the achievements appeared. In retroarch / retropie do not appear the achievements.


Note I'm using the informed core: PC Engine (using Beetle PCE Fast)

meleu
Posted: 04 Mar, 2017 00:48
Where did you get the ROM?

ivesmt666
Posted: 04 Mar, 2017 01:13
Emuparadise .iso and .cue, then convert to .bin as it says on the official website of the retropie, the game opens but the achievements do not appear

MGNS8M
Posted: 04 Mar, 2017 01:21
Last Edit: 04 Mar, 2017 01:24
So, that'd be where one new extra MD5 was added to that set...

Turbo-CDs/PC-Engine-CDs are a bit of a "trick" to get to work.


More or less, when a Turbo-CD gets loaded, RAPCE recognizes and passes the MD5 of the BIOS-FILE to the server instead of any identity of the CUE/ISO itself.

Salsa took advantage of this and began making barely-adjusted BIOS and IPS files of them to change their MD5 just barely enough to be different from the others, and then linked them to different PCE-CD/Turbo-CD games on the site.


Basically the way you load a Turbo-CD game is to grab a fresh PCE-CD-BIOS file, apply one of Salsa's IPS files on it, then when RAPCE asks you to set the HU-System-Card, you use the one that points to your game and then load the CD.

I have no idea how RetroArch could do this, or if it's even possible. This is basically a bug that shouldn't be happening, but we took advantage of it to make it work.

(We also tried to do the same for Sega-CD because it also has this same problem when RAGens loads an ISO-FILE, but first of all RAGens targets the RAM-cart instead of the actual RAM so we can't make achievements anyway, and loading the ISO instead of Booting-CD in RAGens means there's no CD-Audio, and Boot-CD-Mode(which does load the CD-Audio) actually doesn't load the BIOS as a ROM, so it's pointless.)

Ideally, we'd want the RA-Integration to actually identify the CD and make some kind of MD5 or whatever for it and have that on the site, but currently the RA-Integration just doesn't do that....for any CD-system. That's why we used this method to get around it. Otherwise, we couldn't run them at all.


....sooooo, we'll need to unlink and relink Rondo of Blood at some point, and hopefully get that extra standard-BIOS pointed to the null-group. But also, Rondo of Blood's achievements are pretty badly-made and the set kind of needs to be remade almost entirely really. If you load the wrong CD with a BIOS that points to Rondo of Blood, it will just start randomly popping achievements, so that's no good.

leiradel
Posted: 05 Mar, 2017 00:41
, so basically there's one HuCard with a slightly different CD-ROM BIOS for each CD-ROM game, and you use them in pairs with RAPCE, right? RAPCE will then use the HuCard hash to identify the game to avoid hashing the entire CD-ROM.

RetroArch can identify PS1 and PSP games without hashing the entire disk image; for those systems it uses the disk serial identifier instead of calculating the hash. It would be great if we could extend it to also recognize PCE CD-ROM images.

Do PCE CD-ROMs have labels that uniquely identify a game? If not, maybe we could hash part of the image, say the root folder, or maybe just the game executable in the image? It shouldn't be too hard to parse the root folder and find where in the image a file is.

MGNS8M
Posted: 05 Mar, 2017 02:56
Yeah, it's a sort of paring-system.

Well, it'd be nice if the official emus had that ability to check the serial-identifier ... I know Gens/RAGens can grab the CD-title from the game, whether it's the original disc/virtual-drive or the ISO, but that wouldn't be nearly as good as an actual serial. But I guess that bare title could be "hashed" and sent, although it wouldn't be very "secure" in the sense that anyone could manipulate it.... I guess? Just musing out loud on that one, I really kinda wish Sega-CD worked in some way that preserved the Audio(but then we'd also have to figure out why the RAM isn't being targeted correctly as well).

In thinking about it, if the method mentioned of converting ISO to BIN could produce the same MD5 and RAPCE could load it, we could attempt to do that in RAPCE and link the correct BIN as a PCE to the set here. But ... I have no idea what RetroArch / RetroPie is hashing or checking for PCE/Turbo-CD games ... or if it is hashing anything at all. Also I kinda doubt RAPCE would load it long enough for the add-game menu to come up. We'd need to check for some kind of output from RetroArch to see if it's sending anything, and if it is, attempt some weird way of trying to link that exact MD5 to the set here. It's just too bad we can't manually add MD5s to each set... right now we can't even see them due to a new glitch that always says there are zero MD5s attached.

meleu
Posted: 19 Apr, 2017 18:59
Last Edit: 19 Apr, 2017 19:02
Hey guys, Master System cheevos are working on RetroArch! :-)

Update your picodrive and try to see with your own eyes.

Kudos to .

ivesmt666
Posted: 19 Apr, 2017 19:26
Nice show, falta atualizar o site agora ahhahah show de bola

hansolo77
Posted: 20 Apr, 2017 15:13
Can't wait to try. I'm excited to see Master System cheeves finally!
Page: < 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 >

login

login to retroachievements.org:
User: 
Pass: 
or create a new account