login to retroachievements.org:
User: 
Pass: 

log of experiences with RetroArch and-or the achievement itself

Page: 1 2 3 4 5 6 7 8 9 10 11 12 >
AuthorMessage

meleu
Posted: 16 Apr, 2016 23:31
Last Edit: 15 Nov, 2016 23:37
UPDATE
We realized that it's easier to manage the issues using the issue tracker of the RetroArch-problematic-cheevos repository (https://github.com/meleu/RetroArch-problematic-cheevos/issues ). It's because each game issue has its own thread to discuss.

Many of you reported several problems since I started this thread, and then some great fixes were done to RetroArch. My problems with NES cheevos were solved, some issues on Game Boy and Game Boy Color reported by were solved, an SNES issue on Kirby Super Star reported by was solved (13-November-2016, update your RetroArch from source)...

That said, unless you guys report them again, we are considering all those initial problems as solved and that currently RetroArch has no (reported) issues related to RetroAchievements with these systems:

- Mega Drive (using picodrive)
- NES (using QuickNES)
- Game Boy Advance (using mGBA)
- Game Boy / Game Boy Color (using gambatte)
- PC Engine (using Beetle PCE Fast)
- SNES (using Snes9x 2010, previously known as Snes9x Next)

If you redo the tests and find the same problem, please report it again using the issue tracker: https://github.com/meleu/RetroArch-problematic-cheevos/issues

Really important: providing savestates right before getting the problematic cheevos increases a lot the chance to get it solved. If you don't know how to make Pull Request to send savestates to RetroArch-problematic-cheevos repository, you can easily attach files to an issue when you create one in the issue tracker. And then I put it in the repository.


If you would like to show your love for the RetroArch, consider a donation: https://www.patreon.com/libretro


ORIGINAL POST:

My friends ( and ) and I choose 2-3 NES/MegaDrive/SNES games every other week trying to earn some achievs. Our favourite platform is RetroArch on Android due to it's portability, and RetroPie due to it's coolness :-)

This is our current enviroment:
RetroArch 1.3.4 (on Android or RetroPie 3.8)
NES emulator: fceumm
SNES emulator: snes9x-next (or armsnes, on RetroPie for raspi1).
MegaDrive emulator: picodrive

If I say RetroArch in a NES game context, I mean fceumm; MegaDrive context, I mean picodrive; SNES context, I mean snes9x-next or armsnes.

Here we'll try to log the problems we face with RetroArch or the achievement itself.


NES Games

: fully OK!

: THIS PROBLEM WAS SOLVED![RetroArch problem] the Bonus Areas achievements doesn't work on RetroArch, and work OK on RANes.

: the 3 Hi-Scores achievements popped out just with the loading of the game. The "funny" achievements (Don't press Left in the Jungle, Win first stage without touching water, Get electrocuted, etc.) don't work are working fine after the latest fixes. The Beat Levels achievs work OK.

: THIS PROBLEM WAS SOLVED![RetroArch problem] Some hidden treasures achievements don't work on RetroArch but work on RANes. But we didn't play this game seriously yet. Maybe I'll update this later.

: THIS PROBLEM WAS SOLVED![RetroArch problem] The "Obtain [Weapon]" achievements don't work. On RANES they work OK.

: No problems found. I didn't get the really challenging achievements. But everything seems to work fine.

: Same as above.

: Same as above.

: Same as above.

: Same as above.

: Same as above


SNES Games

: [achievements problem]
- The Defeat-Boss-Without-Taking-Damage achievements actually is "Defeat Boss with your life bar full". If you arrive at the boss with some damage and defeat the boss without taking damage, you won't get the achiev.
- I finished the game with Wolverine without any password, and the Achievement didn't work.


MegaDrive/Genesis Games

Until now, no problem was found. The games played:












Cabrunco
Posted: 17 Apr, 2016 00:46
in fact no mega game presented issues yet.

leiradel
Posted: 27 May, 2016 15:48
Last Edit: 27 May, 2016 15:49
Hi, I'm the author of the achievements module for RetroArch.

RetroArch has an well-defined interface to work with its emulators (we call them cores), and the way this interface works is different from what RetroAchievements emulators do to access the emulated memory and check for achievements. Because of that difference, some problems are bound to happen.

I'll take a look at some of these issues, but I don't have time to play through all the games looking for issues :) If you can put savegames right before completing problematic achievements somewhere so I can take a look it would be awesome.

Thanks for creating this thread, I'll keep an eye on it to improve the RetroAchievements experience when using RetroArch.

Cheers!

meleu
Posted: 28 May, 2016 14:13
Finally I found the person I was looking for! :D
I've been asking for you at libretro forums

I'll edit this post to update some games and try to put the savestates you've requested.

A huge thank you for implementing RetroAchievements on RetroArch!
:D

Having RetroArch with RetroAchievements on my Android phone is an amazing thing! This is a life-changing piece of software!

meleu
Posted: 28 May, 2016 14:20
Let me ask one more thing: what's the purpose of the "test unofficial" option?

leiradel
Posted: 29 May, 2016 04:26
LOL, yes, I only saw that forum post long after your post, and I thought the conversation would be lost there.

The savestates will be very important to iron out the remaining issues with the achievements module in RetroArch. Thanks in advance for your help!

Regarding the "test unofficial" option, it does the same thing as in the RetroAchievements emulators: it tests achievements that are not yet deemed official by the community here.

Cheers!

meleu
Posted: 03 Jun, 2016 21:06
Last Edit: 04 Jun, 2016 02:50

I created a github repo to upload the savestates: https://github.com/meleu/RetroArch-problematic-cheevos

Today I uploaded some states about the problematic Double Dragon (NES) achievements.

More to come...

Hope it helps!

Grenade44
Posted: 13 Jun, 2016 20:49
Last Edit: 09 Nov, 2016 07:08
hi, Ive been trying to get GB, GBC and GBA achievements working but have come across some issues with all games ive tried.

Emulators
GB/GBC Im using lr-gambatte
GBA Im using vba_next
Nes Im using fceumm
MegaDrive im using picodrive

GB
"Getting Horny..." doesnt unlock Works like a treat now
"Cubit (Round 1)" didn't unlock also works now

GBC
unlocks 9 achievements when game starts. Works now
unlocks "Runaway TRIO" when rom is loaded. "Rocket Rage, Rocket Radio" both unlock when you use the ingame save option. I also defeated Falkner and "Flying Monk" didnt unlock.

GBA
unlocks Hero of the Day, A Fungus Amongus when game starts.
doesnt unlock "I Choose You!".
Unlocks 3 achievements on main menu.(check my profile)

MegaDrive
Unlocks "World Tour - Duckbur" & "Quack Attack!" when game starts
Unlocks "Best Rat Ratzo 500" when staring the game

Nes
Unlocks "Energy Tank", "Getting A Head" & "The Birds" when game starts

Grenade44
Posted: 14 Jun, 2016 13:56
I would like to help with save states for gameboy games. How do i upload save states to your github repositorie?

hansolo77
Posted: 17 Jun, 2016 01:43
Last Edit: 17 Jun, 2016 01:44
I'm actually glad I found this thread. I'm using RetroArch on my RPi2 and have been having difficulty earning achievements as well. Granted, I've only been just experimenting to make sure I have my setup correct (fresh install, need lots of time to configure, etc). But specifically.. I played a LOT of



And didn't earn ANY achievements. I tried different cores, and found that while gpSP is by far the best at running (at least in my case), it pops up a line that says it doesn't work with cheevos. mGBA seems to run well in comparison, and doesn't give me that error. But I wasn't able to earn anything. Playing the Mario Bro's Classic game, I figured completing Level 5 would be simple enough. In fact, I reached Level 7 before completely Game Over-ing, and never earned anything. If you look at my profile though, I believe it shows that I was playing that game. So I'm kinda lost. This is the first (and so far ONLY) game I've tried playing though, so I might have better luck with something else.

I do find it interesting though that shows that game specifically unlocks 2 cheevos right from the start, whereas it didn't in my case.

Is there a list somewhere that shows what cores specifically work with with RetroArch and RetroAchievements?

Grenade44
Posted: 17 Jun, 2016 06:36


This is taken off the official Retropie wiki page

Supported Systems:
•Game Boy / Color (lr-gambatte - installed by default)
•Game Boy Advance (VBA-M - installed by default, mGBA - installed by default)
•NES (lr-fceumm - installed by default, lr-QuickNES - found in 'Experimental' menu)
•SNES (lr-Snes9x-next, lr-pocketsnes, lr-armsnes - installed by default)
•Genesis/Mega Drive (lr-picodrive - installed by default)

That's interesting about super Mario, that i got 2 achievements loading the game and you didn't. What rom u using? Country and version?

I'm using vba-next which I think is a fork, can't find vba-m on Retropie.

hansolo77
Posted: 18 Jun, 2016 01:16
I'll take a look and see if vba-next was installed and see if that works better. In my particular case, I'm not sure which ROM I'm using. I've installed GameStarter and IARL on my RPi2.. so the ROM is whatever IARL downloaded. On my main gaming computer I do have a full collection of No-Intro ROMs, so maybe that might work better. I'll try some other things out and see what I can come up with.

GameDragon
Posted: 01 Jul, 2016 18:11
Last Edit: 06 Jul, 2016 15:50
Trying Retroarch for the first time, I'm going through

Most of the achievements worked perfectly except for the following two:



They worked perfectly in RASnes9x.

Also gave a try. Djinn achievements seemed to work fine but the following did not:



Astariah
Posted: 27 Jul, 2016 17:31
Hey I got a problem. When I load a game and check the achievement list they all show unlocked so nothing pops up in game when I do the requirement and I'm using Android phone

Grenade44
Posted: 27 Jul, 2016 19:16
If I remember correctly that's just a bug in the emulator which was fixed in a nightly. Have u updated your emulator? And I think you can still earn achievements even tho it says unlocked but don't hold me to that.
Page: 1 2 3 4 5 6 7 8 9 10 11 12 >

login

login to retroachievements.org:
User: 
Pass: 
or create a new account